blob: 87432767217b749caf779ad3722c41107bf02426 [file] [log] [blame]
//===----------------------------------------------------------------------===//
//
// The LLVM Compiler Infrastructure
//
// This file is dual licensed under the MIT and the University of Illinois Open
// Source Licenses. See LICENSE.TXT for details.
//
//===----------------------------------------------------------------------===//
// <utility>
// template <class T1, class T2> struct pair
// template <class T1, class T2> void swap(pair<T1, T2>& x, pair<T1, T2>& y);
#include <utility>
#include <cassert>
int main(int, char**)
{
{
typedef std::pair<int, short> P1;
P1 p1(3, static_cast<short>(4));
P1 p2(5, static_cast<short>(6));
swap(p1, p2);
assert(p1.first == 5);
assert(p1.second == 6);
assert(p2.first == 3);
assert(p2.second == 4);
}
return 0;
}